OpenBSD Amsterdam Logo
800 VMs deployed 🐡

Finishing touches

Known issues

There are currently a couple of known issues.

Connecting to your VM

Your VM is a clean install of OpenBSD 7.4-release + errata. You can ssh into it:

vmXX$ ssh username@XXX.XXX.XXX.XXX
OpenBSD 7.4 (GENERIC) #1336: Tue Oct 10 08:52:22 MDT 2023
...
vmXX$

Get the password from ~/.ssh/authorized_keys and switch to root.

vmXX$ awk '{print$NF}' .ssh/authorized_keys
XXXXXXXXXXXXXXXXXXXXXXXXXX
vmXX$ su -
Password:
vmXX#

Add your username to /etc/doas.conf:

vmXX# echo 'permit username' > /etc/doas.conf
vmXX# echo 'permit nopass keepenv root as root' >> /etc/doas.conf
vmXX#

All errate should be applied, but you can check 7.4 errata and apply available patches.

vmXX# syspatch
...
Relinking to create unique kernel... done; reboot to load the new kernel
Errata can be reviewed under /var/syspatch
vmXX# reboot
Connection to XXX.XXX.XXX.XXX closed by remote host.

Preventing password logins to your VM with ssh. (optional)

vmXX# rcctl set sshd flags -o PasswordAuthentication=no
vmXX# rcctl restart sshd
vmXX#

Easily set and manage your PTR / Reverse DNS records.
Protect your important data with our Backup Service.

Connect to the console

To get connected to the console you need to have access to the host your VM is running on. The same username and public SSH key, as provided for the VM, are used to create a local user on the host.

All SSH fingerprints (SSHFP) records of all the hosts are added to DNS. You can verify the SSH fingerprint by adding “-o VerifyHostKeyDNS=yes” to the ssh command.

$ ssh -e none -p PORT -o VerifyHostKeyDNS=yes serverXX.openbsd.amsterdam
The authenticity of host '[serverXX.openbsd.amsterdam]' can't be established.
ED25519 key fingerprint is SHA256:Wi1k5YbFY+o0y4ygaRmsI9+S/0k5FB3OvgKCvtaHS/k.
Matching host key fingerprint found in DNS.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
...
serverXX$

You can also use mosh to connect to the host. We added a short write-up on how to use mosh on your own VM.

When this is done you can use vmctl(8) to manage your VM.
The options you have are:

serverXX$ vmctl console vmXX
serverXX$ vmctl stop [-fw] vmXX
serverXX$ vmctl start [-c] vmXX
serverXX$ vmctl start [-c] [-b path] vmXX

-f Forcefully stop the VM without attempting a graceful shutdown.
-w Wait until the VM has been terminated.
-c Automatically connect to the VM console.
-b path Boot the VM with the specified OpenBSD kernel. For example /var/vmm/bsd.rd.

~. To exit the console, which uses cu(1)

Note: id can also be your VM name.